php - Composer create project issue


I am getting the following error while creating project

C:\MAMP\htdocs>composer create-project laravel/laravel testing 5.2

Your version of PHP, 5.4.1, is affected by CVE-2013-6420 and cannot safely perform certificate validation, we strongly suggest you upgrade.




This means that your version of PHP is too old and has known vulnerabilities. You should upgrade the PHP version to at least 5.6, but I would recommand to upgrade directly to 7.0 or 7.1. They are under active support (until dec 3rd for 7.0) and have better perfomance.

Moreover laravel 5.2 needs a PHP version >= 5.5.9. It's written in the requirements.

Here is the supported version chart of PHP. You shouldn't use any version that is in red.




you need update your PHP version source : so PHP 5.5.9 + for you :)

PHP 5.5.9+ Since PHP 5.4 will enter "end of life" in September and will no longer receive security updates from the PHP development team, Laravel 5.1 requires PHP 5.5.9 or greater. PHP 5.5.9 allows compatibility with the latest versions of popular PHP libraries such as Guzzle and the AWS SDK.

People are also looking for solutions to the problem: javascript - Chartjs dynamic chart return both x & y axis undefined


Didn't find the answer?

Our community is visited by hundreds of web development professionals every day. Ask your question and get a quick answer for free.

Ask a Question

Write quick answer

Do you know the answer to this question? Write a quick response to it. With your help, we will make our community stronger.

Similar questions

Find the answer in similar questions on our website.