php - Migrate multi-site error

469

I have migrated a WordPress multi-site to a subdomain. WordPress verion is 3.1 and PHP version in 5.4.

I am getting this warning: "Warning: Creating default object from empty value in ///public_html/wp-includes/ms-load.php on line 139"

Any one can help in this.

Thank you,

779

Answer

Solution:

Unfortunately, shared hosts always have display_errors on. To turn this off yourself, you can attempt to modify your WordPress config.

1.Connect to your server via FTP

2.Download a copy of the wp-config.php and open it in a text or HTML editor Find the following section and ensure WP_DEBUG is false:

/** * For developers: WordPress debugging mode. * * Change this to true to enable the display of notices during development. * It is strongly recommended that plugin and theme developers use WP_DEBUG * in their development environments. */

define('WP_DEBUG', false);

4.Paste the following line right below the WP_DEBUG line: ini_set( 'display_errors', 0 );

5.Save and re-upload the file to your root directory or wherever WordPress is installed.

If this does not work, you will need to contact your host about disabling PHP debugging/error display for your site.

People are also looking for solutions to the problem: php - Combine 2 arrays into a third array with inconstant unique keys from one array

Source

Didn't find the answer?

Our community is visited by hundreds of web development professionals every day. Ask your question and get a quick answer for free.

Ask a Question

Write quick answer

Do you know the answer to this question? Write a quick response to it. With your help, we will make our community stronger.

Similar questions

Find the answer in similar questions on our website.